恒泰艾普股票通达信三角形中枢主图指标公式

恒泰艾普股票通达信三角形中枢主图指标公式

恒泰艾普股票通达信三角形中枢主图指标公式

{三角形中枢}时间:=4;A:=H=HHV(H,时间*5) AND HHV(H,时间*5)>REF(HHV(H,时间*5),1);B:=L=LLV(L,时间*5) AND LLV(L,时间*5)<REF(LLV(L,时间*5),1);CC1:DRAWLINE(A,H,B,L,0);CC2:DRAWLINE(B,L,A,H,0);N:=(0,1,1);{缠论高低点}局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));距前高天:=BARSLAST(局部高点预选C=1);距前低天:=BARSLAST(局部低点预选C=-1);小值周期:=LOWRANGE(L);大值周期:=TOPRANGE(H);低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);距前高天A:=BARSLAST(高保留=1);距前低天A:=BARSLAST(低保留=-1);预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);距前高天YA:=BARSLAST(高保留X=1);距前低天YA:=BARSLAST(低保留X=-1);预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)),CIRCLEDOT,COLORLIMAGENTA;C1:DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0),COLORLIGRAY;C2:DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0),COLORLIGRAY;极顶:=IF(N=1,C2=C1 AND 局部高点预选A AND 极点保留=1,DRAWNULL);极底:=IF(N=1,C2=C1 AND 局部低点预选A AND 极点保留=-1,DRAWNULL);A1:=BARSLAST(极顶);B1:=CURRBARSCOUNT=CONST(A1)+1;D1:=BARSLAST(B1);高1:=CONST(REF(H,D1));A2:=REF(A1,A1+1)+A1+1;B2:=CURRBARSCOUNT=CONST(A2)+1;D2:=BARSLAST(B2);高2:=CONST(REF(H,D2));A3:=REF(A2,A1+1)+A1+1;B3:=CURRBARSCOUNT=CONST(A3)+1;D3:=BARSLAST(B3);高3:=CONST(REF(H,D3));DA1:=BARSLAST(极底);DB1:=CURRBARSCOUNT=CONST(DA1)+1;DD1:=BARSLAST(DB1);低1:=CONST(REF(L,DD1));DA2:=REF(DA1,DA1+1)+DA1+1;DB2:=CURRBARSCOUNT=CONST(DA2)+1;DD2:=BARSLAST(DB2);低2:=CONST(REF(L,DD2));DA3:=REF(DA2,DA1+1)+DA1+1;

恒泰艾普股票

DB3:=CURRBARSCOUNT=CONST(DA3)+1;DD3:=BARSLAST(DB3);低3:=CONST(REF(L,DD3));三角型放大A:=低1<低2 AND 高2>高1 AND DA2>A1 AND A1>DA1 AND A2>DA2 AND CONST(C)>低2;中枢A1:=IF(三角型放大A AND CONST(C)<高1,DB2,DRAWNULL);STICKLINE(中枢A1,CONST(C),低2,0,0),COLORLIMAGENTA;中枢A2:=IF(三角型放大A AND CONST(C)<高1,ISLASTBAR,DRAWNULL);STICKLINE(中枢A2,CONST(C),低2,0,0),COLORLIMAGENTA;DRAWLINE(中枢A1=1,CONST(C),中枢A2=1,CONST(C),0),DOTLINE,COLORLIMAGENTA;DRAWLINE(中枢A1=1,低2,中枢A2=1,低2,0),COLORLIMAGENTA;{成立}中枢AC1:=IF(三角型放大A AND CONST(C)>=高1,DB2,DRAWNULL);STICKLINE(中枢AC1,高1,低1,0,0),COLORLIMAGENTA;中枢AC2:=IF(三角型放大A AND CONST(C)>=高1,ISLASTBAR,DRAWNULL);STICKLINE(中枢AC2,高1,低1,0,0),COLORLIMAGENTA;DRAWLINE(中枢AC1=1,高1,中枢AC2=1,高1,0),COLORLIMAGENTA;DRAWLINE(中枢AC1=1,低1,中枢AC2=1,低1,0),COLORLIMAGENTA;三角型放大B:=低1>低2 AND 高1>高2 AND DA1>A1 AND A2>DA1 AND DA2>A2 AND CONST(C)<高2;中枢B1:=IF(三角型放大B AND CONST(C)>低1,B2,DRAWNULL);STICKLINE(中枢B1,CONST(C),高2,0,0),COLORGREEN;中枢B2:=IF(三角型放大B AND CONST(C)>低1,ISLASTBAR,DRAWNULL);STICKLINE(中枢B2,CONST(C),高2,0,0),COLORGREEN;DRAWLINE(中枢B1=1,高2,中枢B2=1,高2,0),COLORGREEN;DRAWLINE(中枢B1=1,CONST(C),中枢B2=1,CONST(C),0),DOTLINE,COLORGREEN;{成立}中枢BC1:=IF(三角型放大B AND CONST(C)<=低1,B2,DRAWNULL);STICKLINE(中枢BC1,高2,低1,0,0),COLORGREEN;中枢BC2:=IF(三角型放大B AND CONST(C)<=低1,ISLASTBAR,DRAWNULL);STICKLINE(中枢BC2,高2,低1,0,0),COLORGREEN;DRAWLINE(中枢BC1=1,高2,中枢BC2=1,高2,0),COLORGREEN;DRAWLINE(中枢BC1=1,低1,中枢BC2=1,低1,0),COLORGREEN;三角型收敛A:=低1>低2 AND 高2>高1 AND DA2>A1 AND A1>DA1 AND A2>DA2 AND CONST(C)>低1;中枢C1:=IF(三角型收敛A AND CONST(C)<高1,DB2,DRAWNULL);STICKLINE(中枢C1,CONST(C),低1,0,0),COLORYELLOW;中枢C2:=IF(三角型收敛A AND CONST(C)<高1,ISLASTBAR,DRAWNULL);STICKLINE(中枢C2,CONST(C),低1,0,0),COLORYELLOW;DRAWLINE(中枢C1=1,CONST(C),中枢C2=1,CONST(C),0),DOTLINE,COLORYELLOW;DRAWLINE(中枢C1=1,低1,中枢C2=1,低1,0),COLORYELLOW;{成立}中枢CC1:=IF(三角型收敛A AND CONST(C)>=高1,DB2,DRAWNULL);STICKLINE(中枢CC1,高1,低1,0,0),COLORYELLOW;中枢CC2:=IF(三角型收敛A AND CONST(C)>=高1,ISLASTBAR,DRAWNULL);STICKLINE(中枢CC2,高1,低1,0,0),COLORYELLOW;DRAWLINE(中枢CC1=1,高1,中枢CC2=1,高1,0),COLORYELLOW;DRAWLINE(中枢CC1=1,低1,中枢CC2=1,低1,0),COLORYELLOW;三角型收敛B:=低1>低2 AND 高1<高2 AND DA1>A1 AND A2>DA1 AND DA2>A2 AND CONST(C)<高1;中枢D1:=IF(三角型收敛B AND CONST(C)>低1,B2,DRAWNULL);STICKLINE(中枢D1,CONST(C),高1,0,0),COLORLICYAN;中枢D2:=IF(三角型收敛B AND CONST(C)>低1,ISLASTBAR,DRAWNULL);STICKLINE(中枢D2,CONST(C),高1,0,0),COLORLICYAN;DRAWLINE(中枢D1=1,高1,中枢D2=1,高1,0),COLORLICYAN;DRAWLINE(中枢D1=1,CONST(C),中枢D2=1,CONST(C),0),DOTLINE,COLORLICYAN;{成立}中枢DC1:=IF(三角型收敛B AND CONST(C)<=低1,B2,DRAWNULL);STICKLINE(中枢DC1,高1,低1,0,0),COLORLICYAN;中枢DC2:=IF(三角型收敛B AND CONST(C)<=低1,ISLASTBAR,DRAWNULL);STICKLINE(中枢DC2,高1,低1,0,0),COLORLICYAN;DRAWLINE(中枢DC1=1,高1,中枢DC2=1,高1,0),COLORLICYAN;DRAWLINE(中枢DC1=1,低1,中枢DC2=1,低1,0),COLORLICYAN;