002716通达信抓牛黑马指标公式

002716通达信抓牛黑马指标公式

002716通达信抓牛黑马指标公式

DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,'1',0);VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1); VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1); VAR3:=EMA(VAR2,10);VAR4:=LLV(LOW,33);VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.3,0 ),COLOR000077;STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.3,0 ),COLOR0000BB;STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000DD;STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;拉升:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR005500;STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.3,0),COLOR007700; STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR009900;STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.3,0),COLOR00BB00;STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00DD00;STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00FF00;{黑马}A1:=EMA(C,12)-EMA(C,25);A2:=EMA(A1,6);获利回吐:=(A2>=0)*A2,COLORWHITE,LINETHICK1;大黑马:=(A2<0)*A2,COLORD4FF7F,LINETHICK1;坚绝做空:=(A1<0)*A1,COLORB00058,LINETHICK1;买入持股:=(A1>=0)*A1,COLORRED,LINETHICK1;STICKLINE(A2>=0,A2,0,3,0),COLORWHITE;STICKLINE(A2<0,A2,0,3,0),COLORD4FF7F;STICKLINE(A1<0,A1,0,3,0),COLORB00058;STICKLINE(A1>=0,A1,0,3,0),COLORRED;VAR8:=VOL>2*MA(VOL,30);VAR9:="DMI.ADX"(12,6);VARA:="DMI.ADXR"(12,6);VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));VARF:=TROUGHBARS(3,15,1)<4;VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);VAR11:=IF(VARF=1,50,0);多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;0,COLORRED;STICKLINE(FILTER(VARF=1,5) AND 多空<-10,80,0,3,0),COLORF00FF0;STICKLINE(FILTER(VARF=1,5),60,0,3,0),COLORYELLOW;{DRAWTEXT(FILTER(VARF=1,3),25,'黑马'),COLORRED ;{STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW;STICKLINE(多空>10,0,多空,0.95,0),COLORRED;};周J1:MA("KDJ.J#WEEK"(9,3,3) ,5),COLORGREEN,LINETHICK2;20,COLORMAGENTA,LINETHICK1;80,COLORGREEN;DRAWICON(CROSS(周J1,20),20,1);DRAWTEXT(CROSS(周J1,20),15,'++抄'),COLORRED;DRAWTEXT(CROSS(周J1,80),70,'=追'),COLORYELLOW;{STICKLINE(周J1<0,周J1,0,5,0),COLORLIRED;STICKLINE(CROSS(周J1,0),0,-50,3,0),COLORMAGENTA;DRAWTEXT(CROSS(周J1,0),-35,'———底部'),COLORMAGENTA;}{抓牛黑马VAR1000:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);VAR2000:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;VAR3000:=SMA(SMA(VAR2000,3,1),3,1);VAR4000:=EMA(VAR3000,5);VAR5000:=LLV(LOW,26);VAR6000:=HHV(HIGH,34);VAR7000:=EMA((CLOSE-VAR5000)/(VAR6000-VAR5000)*4,4)*25;{撞坷状?=IF(CROSS(VAR4000,10) AND VAR4000>10,50,0),STICK,COLORYELLOW,LINETHICK3;0,STICK,COLOR000000,LINETHICK3;建仓区: IF((VAR7000<10),20,0), LINETHICK2,COLOR00CCFF ;派发区: IF((VAR7000>90),80,100), LINETHICK2 ,COLORF00FF0;};N1:=9;N2:=5;MTM:=C-REF(C,1);主力轨迹:100*EMA(EMA(MTM,N1),

002716

N1)/EMA(EMA(ABS(MTM),N1),N1),COLORWHITE;MAZL:MA(主力轨迹,N2),COLORYELLOW;VAR1X:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);VAR2X:=SMA(ABS(LOW-VAR1X),13,1)/SMA(MAX(LOW-VAR1X,0),10,1);VAR3X:=EMA(VAR2X,10);VAR4X:=LLV(LOW,33);VAR5X:=EMA(IF(LOW<=VAR4X,VAR3X,0),3);主力进场X:IF(VAR5X>REF(VAR5X,1),VAR5X,0),COLORRED,NODRAW;STICKLINE(VAR5X>REF(VAR5X,1),0,VAR5X,3,0 ),COLOR000055;STICKLINE(VAR5X>REF(VAR5X,1),0,VAR5X,2.3,0 ),COLOR000077;STICKLINE(VAR5X>REF(VAR5X,1),0,VAR5X,2.1,0 ),COLOR000099;STICKLINE(VAR5X>REF(VAR5X,1),0,VAR5X,1.3,0 ),COLOR0000BB;STICKLINE(VAR5X>REF(VAR5X,1),0,VAR5X,0.3,0 ),COLOR0000DD;STICKLINE(VAR5X>REF(VAR5X,1),0,VAR5X,0.3,0 ),COLOR0000FF;洗盘:IF(VAR5X<REF(VAR5X,1),VAR5X,0),COLOR000079,NODRAW;STICKLINE(VAR5X<REF(VAR5X,1),0,VAR5X,3,0),COLOR000079;STICKLINE(VAR5X<REF(VAR5X,1),0,VAR5X,2.3,0),COLOR000093;STICKLINE(VAR5X<REF(VAR5X,1),0,VAR5X,2.1,0),COLOR0000C6;STICKLINE(VAR5X<REF(VAR5X,1),0,VAR5X,1.3,0),COLOR4A4AFF;STICKLINE(VAR5X<REF(VAR5X,1),0,VAR5X,0.3,0),COLOR7D7DFF;STICKLINE(VAR5X<REF(VAR5X,1),0,VAR5X,0.3,0),COLORAAAAFF;VAR21:=SMA(ABS(HIGH-VAR1X),13,1)/SMA(MIN(HIGH-VAR1X,0),10,1);VAR31:=EMA(VAR21,10);VAR41:=HHV(HIGH,33);VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3);主力拉高:IF(VAR51<REF(VAR51,1),VAR51,0),COLORYELLOW,NODRAW;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,3,0),COLOR005555;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.3,0),COLOR007777;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.1,0),COLOR009999;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,1.3,0),COLOR11BBBB;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.3,0),COLOR33DDDD;STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.3,0),COLOR55FFFF;出货:IF(VAR51>REF(VAR51,1),VAR51,0),COLORCYAN,NODRAW;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLORCYAN;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0),COLOR555555;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.3,0),COLOR777777;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.1,0),COLOR999999;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.3,0),COLORBBBBBB;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0),COLORDDDDDD;STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0),COLORFFFFFF;